Welcome to c4dplugin answers.
Here you can ask questions about CINEMA 4D plug-in software by heyne and receive answers from the support team and other users.

Before Asking
Have you tried finding the answer to your question using the search?

How to Ask
Please ask questions that can be answered, not just discussed. For discussion, go to one of the popular Cinema 4D forums

Provide details. Write clearly and simply. See guideline for writing good questions.

Remember to come back and select the best answer as accepted if it is useful to you.

0 votes
DirectControl now works fine on my R20.
However I can not access buttons or hats, because menu indicates only analog joysticks like below.


How can I do this?
CINEMA 4D version CINEMA 4D R20 Studio
in DirectControl :: Game Controller by (120 points)

2 Answers

0 votes
looks like DC cannot detect your controller at all. DC is based on DirectX, so it can only detect controllers that are directly supported by DirectX.

Here is a little DirectX tool, that tests the connected device. If this tool doesn't recognize your controller, DirectControl also won't detect it.

by (920 points)
My old game pad "Hori Pad" may be a clone for PlayStation3, but still works fine in your checker.
Also it works fine in Web game pad checker "HTML5gamepad" (I do not know it uses the DirectX or not).
Did you try the "Test Controls" button? A window should open showing the controllers name in the title bar and controller actions in real time.
Yes I did.
But I found the "blank" controls from 5 to 15 are still working as hat or all buttons.

However if I once change the menu to "No Mapping" or "X", I can not go back to hat nor any buttons.
This is not game pad or OS problem, but gui problem in this plugin.
Quick test of the DirectControl.
It worked fine with blank menu.

Please test the scene file, and is the menu still blank or displays some button names?
I did another test with CINEMA 4D R17 and DirectControl demo.
All other things are same(hardwares, OS, gamepad, VNC) as previous test.


Then the plugin works, and shows all menues include button or hat, however still text is wrong.

Also the text is not written in resource file but directly in program. So I can not fix it. Did you test your plugin on Japanese or other languages from de or us? For such cases, MAXON divided resource text from program and took unicode at R6, because it is much easier to fix such problems and translate.

Please move the text from program to resource file, then I will fix it, and translate to Japanese (to say other words, make strings_jp folder).
0 votes
Are you running Windows as an emulation on a Mac? You should have tested your controller with the trial version before purchasing. We cannot test our software with all existing controllers.
by (2.7k points)
I am using Intel NUC with Windows10 pro like that.

And the screen movie was captured on my iMac through "VNC".